Jump to content

tournament timer is inaccurate


semeai

Recommended Posts

today I was in the finals of a tournament and it was a long and intense game. I saw it was going to come down to timers, and I had 1:33 minutes left vs my opponent's 0:36 seconds left. but the opponent played his move, and in the beginning of my turn I instantly lost for some reason. There was no stadium in play, I had 5 cards in my deck vs my opponent's 3, and I had 3 prizes left vs my opponent's 4 prizes.

 

I can only think that the loss was due to my timer being inaccurate and i actually had less than the time it indicated. The 15 second clock did NOT show, and usually it ticks down to 0 if your timer is about to hit zero. 

 

The tournament in question was played, based on my tournament history, at 9/7/2016 4:04:30PM

 

I want to know what happened, and if the reason is the timer, it needs to be fixed. you can't have it be off by over a minute, that is ridiculous.

Link to comment
Share on other sites

  • 3 weeks later...

I feel your pain. I too just had this happen and had more time than my opponent during a long game and was about to win. I then got booted and my opponent advanced. Stinks to put in all that time just to lose due to what I believe is an in game error on the clock.

Link to comment
Share on other sites

This thing happend three times to me, i filed a support ticket with screenshots and other info but i didn't get any response . Once my opponent ran out of time and i lost the game , this is ridiculous and needs to be fixed please.

Link to comment
Share on other sites

If this is the same bug that I remember, I'm surprised that it's still sticking around. There used to be a bug were, after you ended your turn, the game would incorectly keep the timer going for a second or so but not display it. After several turns the total time loss not being displayed can count up to over a minute in a normal match.

 

It's not very notorious in VS due to the large total timer but it has definetly caused several surprise losses in tournaments in the past. I hope this helps find the cause, in case this is in fact the very same glitch.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...