Jump to content

start up


ferapoleott

Recommended Posts

Hi ferapoleott,

 

Please ensure that you have the newest video driver for you system, downloaded from the manufacturer's website.

 

This could be a resolution issue. Try a right click on your desktop -> screen resolution, lower resolution, load TCGO. If you make it in, go to your in-game Settings and change your game resolution so that you can return your desktop resolution to its default.

 

Also, if you run Windows Defender, please make sure that it is not blocking TCGO.

 

Thanks!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...