Jump to content
Sign in to follow this  
mario470

Darkrai Ex's Dark Cloak Bug

Recommended Posts

mario470

I had two basic dark energies attached to my active Darkrai Ex and I wanted to retreat it. It was supposed to retreat it without cost due to its Dark Cloak Ability but two dark energies were discarded in that retreat. Does anyone encounter such a problem?

This is quite annoying since Darkrai Ex is quite a major card in the game. Hope they will fix it soon.

Share this post


Link to post
Share on other sites
chronophysicist

was garbotoxin in effect? if not I believe this issue was mentioned by someone before but can't be sure.

Share this post


Link to post
Share on other sites
mario470

I am sure that Garbatoxin was not in play.

Also, I had glanced through this forum to make sure that I don't make a double-report before I reported this bug.

Share this post


Link to post
Share on other sites
gravybeast

I second this. I was playing against a strict Staraptor deck just now. That's all he played. I could retreat other pokemon that had dark energy attached to them but when I tried to retreat Darkrai, it would discard 2 energy.

Share this post


Link to post
Share on other sites
jbcheshire

I've had this happen to me when I was playing against a Garbodor that just had its tool scrapped away...

Share this post


Link to post
Share on other sites
gravybeast

Another note on this bug... It only happens if you have 2+ energy attached to the Darkrai. If you only have 1 energy the ability works and nothing is discarded. If you have 2+ energy it seems like something in the games logic notices you have enough energy to retreat and discards the energy.

Share this post


Link to post
Share on other sites
TPCi_Mathis

The programmers changed the coding for Dark Cloak for Wednesday's update in an attempt to permanently resolve the recurring conflicts with other Abilities, such as Garbotoxin and Overflow. It looks like they introduced a new bug in the process. I was able to reproduce this bug yesterday 4 or 5 times over 8 games. Unfortunately, I was unable to nail down a solid set of repro steps, so the bug I entered into the database was a big vague. I was able to get Dark Cloak to fail on some Pokemon, but continue working on others. I don't know if it's tied to quantity of Energy attached, damage counters on the Pokemon, effects from an opposing attack, or what, but the QA team is now aware of the issue an attempting to create reliable repro steps so that the programmers can fix this bug.

Share this post


Link to post
Share on other sites
supercripple

It seems to happen most often when the Pokemon is damaged. It happened to me just now when I only had one energy attached, so I know it's not about the quantity. This is getting really annoying. >.<

Share this post


Link to post
Share on other sites
AY89

Yeah, I can't play this game with this bug. I'll play AIs to try and see the cause

 

EDIT: The only common factor I can see so far is both Darkrai and Hydreigon on the field. Were these one of the abilities that it had conflicts with?

 

When you start moving the energies around, you can see the ability for Darkrai to retreat appearing and disappearing. Seems like when you move all energies off Darkrai, then back on, it can retreat again, but after you start moving the energies around again, it will disappear. I'm not exactly sure on repro steps either, but hope this helps.

 

Seems to be triggered by other Pokemon with abilities (that interact with Darkrai's ability in some way..?)

 

Okay, may not have to do with other Pokemon. Encountered it again when only EX pokemon with ability is Darkrai

Edited by AY89
additional info

Share this post


Link to post
Share on other sites
TPCi_Mathis

The Dev team has identified a couple of different issues with passive Abilities, including Dark Cloak and Dark Aura. They've put the fix up on the internal test servers and QA will roll it into their testing schedule. I don't have a timeframe for when they'll deploy the fix to the public, but I'll keep you posted.

Share this post


Link to post
Share on other sites
FreshTomato

This also happened to me just now, a fix would be appreciated :)

Share this post


Link to post
Share on other sites
TPCi_Mathis

The Dev team just completed a server-side fix for the issue affecting Dark Cloak. It should now be functioning properly. If you continue to experience issues with this card, please create a new thread and provide the exact steps necessary to reproduce the problem.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...